WPA2 Vulnerability

Having issues with Star Citizen or need other help with troubleshooting your computer. Come ask our gurus here!

by CrueOndanet » Mon Oct 16, 2017 9:52 pm

TL;DR - WPA2 vulnerability :
Attacker redirects your device to use a Rogue AP & attempts to strip SSL as part of a Man-in-the-Middle Attack (MitM)

Small Details:
If the websites you visit are properly configured, then it should deny non-SSL connections where SSL is needed/required.
If you pay attention to the webpages you visit & they lack the SSL encryption icon, then you know you're being attacked.

iOS11 is protected, but not fully mitigated from the vulnerability. (As of Oct. 16th)

Windows is patched as of Oct. 10th, 2017

According to several sources it looks like the exploits have been addressed in the BETA for iOS, tvOS, watchOS, and macOS that are currently available to developers, and will be rolling out to consumers soon.™

Google Pixel, and other Android devices, won't see an update available till November 6th.

Light reading - https://www.krackattacks.com/
User avatar
CrueOndanet
Assistant Director
 
Posts: 642
Joined: Sun Mar 15, 2015 5:14 pm
Location: TEXAS

Return to Technical Support

Who is online

Users browsing this forum: No registered users and 1 guest